Module werden ausgeblendet bei Weiterlesen Beiträgen

In Joomla kann sich das Problem ergeben, dass die Module nicht mehr angezeigt werden, wenn ein weiterlesen-Beitrag in der Vollansicht geöffnet wird. Beispiel: Die Startseite zeigt im Blog-Styl News Beiträge an. Diese bieten über Weiterlesen eine Vollansicht. Wird diese Vollansicht geöffnet, wird ein Module nicht mehr angezeigt, das zuvor auf der Startseite eingeblendet war. Bei mir war das z.B. ein Split-Menü, das heisst, das Menü ist dann einfach verschwunden.

Folgende Konfiguration löst das Problem…

Ausgangslage:

Ich hatte Beiträge, die waren nicht kategorisiert, aber hatten das Flag gesetzt: Anzeigen auf der Startseite. Die Startseite hat diese Beiträge im Blog-Style schön angezeigt. Auf der Startseite habe ich links noch einen Modul- user-Bereich – mein Submenü. (Grundsätzlich kann das aber auch jedes andere Modul betreffen.)

Lösung:

Werden die Beiträge einer Kategorie anghängt, die über einen Menüeintrag verfügt, dann kann im das Modul (welches angezeigt werden soll) auch entsprechend konfiguriert werden.

Schritt 1.
Eine Kategorie neu anlegen, alle betroffenen Beiträge dieser Kategorie zuweisen.

Schritt 2.
Einen neuen Menüpunkt des Typs Kategorie-Blog anlegen. Diese verweist auf die in Schritt 1 angelegte Kategorie

Schritt 3.
In der Modul konfiguration zu dem Modul gehen, welches eingeblendet werden soll. Dieses Modul nun in der Menüzuweisung so konfigurieren, dass es auch aktiv ist für den in Schritt 2 erstellten Menüpunkt.

Ich merke, dass es etwas schwierig ist zum sauber erklären, aber ich hoffe dass ich das später noch kapiere ;) bzw. es jemandem anderen auch weiter hilft. Ansonsten einfach eine Nachricht an mich. Möglicherweise bin ich auch nur auf Grund einer vielleicht etwas speziellen Struktur der Beiträge auf dieses “Problem” gestossen.

Leave a Reply

  

  

  

*